note 71116 added to install.unix

From: Date: Mon, 13 Nov 2006 08:49:37 +0000
Subject: note 71116 added to install.unix
Groups: php.notes 
Request: Send a blank email to php-notes+get-119650@lists.php.net to get a copy of this message
In response to the guy who posted about the SELinux: I am new to linux/apache/php (coming from server 2003/IIS/Asp.Net), so i was stumped as to why php/apache could only use static content. Also, it couldn't access some documents that you created somewhere else, and then dragged into the HTML directory. After some research, i found the problem was the SELinux context of the files. It took me forever to find the Proper command to use to change that, as all the examples on the net were out dated using old commands: # chcon "user_u:object_r:httpd_sys_content_t" /var/www/html -Rc This will change the SELinux context of all the documents under the /var/www/html directory (which is the web directory under Fedora), to allow the httpd process to access them, and the '-Rc' flag will make the changes Recursive, and will output it's progress for each file that it sucessfully changes. ---- Server IP: 64.71.164.2 Probable Submitter: 66.161.182.137 ---- Manual Page -- http://www.php.net/manual/en/install.unix.php Edit -- https://master.php.net/note/edit/71116 Del: integrated -- https://master.php.net/note/delete/71116/integrated Del: useless -- https://master.php.net/note/delete/71116/useless Del: bad code -- https://master.php.net/note/delete/71116/bad+code Del: spam -- https://master.php.net/note/delete/71116/spam Del: non-english -- https://master.php.net/note/delete/71116/non-english Del: in docs -- https://master.php.net/note/delete/71116/in+docs Del: other reasons-- https://master.php.net/note/delete/71116 Reject -- https://master.php.net/note/reject/71116 Search -- https://master.php.net/manage/user-notes.php

« previous php.notes (#119650) next »