note 72234 deleted from ref.mhash by nlopess
| From: | nlopess@php.net | Date: | Mon, 08 Jan 2007 23:01:29 +0000 |
| Subject: | note 72234 deleted from ref.mhash by nlopess | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-121468@lists.php.net to get a copy of this message | ||
Note Submitter: dave bachtel at look around dot com
----
An interesting issue to note when using this library on Win32 (PHP 4.4.0 - just FYI).
After enabling the Mhash module in php.ini, Apache was failing when trying to load php_mhash.dll
(and ONLY php_mhash.dll) on startup.
It turns out that php_mhash.dll (in the extensions directory) depends on libmhash.dll, in the php
directory.
The fix is to copy libmhash.dll to %systemroot%\system32 (C:\windows\system32), and restart apache.
For more information, see the very helpful original post by Peter Bates here:
http://bugs.php.net/bug.php?id=26837
I hope this is useful to someone else.