note 33521 deleted from language.operators.logical by colder
| From: | colder@php.net | Date: | Fri, 20 Apr 2007 15:39:10 +0000 |
| Subject: | note 33521 deleted from language.operators.logical by colder | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-125699@lists.php.net to get a copy of this message | ||
Note Submitter:
----
in answer to braintreno:
The second example you brought is the correct way to do it! It is not convoluted logic at all, it is
what makes your code readable by not relying on obscure side effects!! It is much easier to read
than the first one and it is by far easier to maintain.
For the idea to let a CheckThisOrOther() funtion echo information to the user alone, you should be
stripped of your coding licence. If i ever had to maintain on of your scripts, I'd have to hate
you.
This is not meant as flame bating as it might sound! Source code is not written for computers to
execute, but for coders to read! Keep that at heart and your co-workers will thank you for it!