note 74677 added to function.session-module-name
| From: | mc at slidetheweb dot com | Date: | Mon, 23 Apr 2007 03:56:01 +0000 |
| Subject: | note 74677 added to function.session-module-name | ||
| Groups: | php.notes | ||
| Request: | Send a blank email to php-notes+get-125785@lists.php.net to get a copy of this message | ||
During a long search for a remedy against the dreaded session start failure errors i may have found
one;
The error : session_start(): Failed to initialize storage module
A socalled 'Strong workaround' is :
--------------------
Edit your php.ini this way:
auto_prepend_file = /usr/local/lib/php.ini.prepend
On your /usr/local/lib/php.ini.prepend file put this:
<? session_module_name("files"); ?>
--------------------
For me this had immediate results.
I am running apache2 with PHP4.3.9 and had years of problems with this error. It popped up without
any logic, we tested this in various ways. The only doubtfull case wich we had was with simultaneous
visitors but even that was doubtfull and could not be repeated continuously.
Today when trying this new solution the immediate result was... no more errors. Errors wich could
be triggered easily can't be found no longer. I have a failure monitor running and will update
this note if i find another error but i have good hopes that this patch will hold php from buggering
out on us.
Last but definitly not least.. thanks to AgustÃn Povarchik from FuturaHost.Com for advising this
solution!
----
Server IP: 194.109.193.76
Probable Submitter: 212.238.246.84
----
Manual Page -- http://www.php.net/manual/en/function.session-module-name.php
Edit -- https://master.php.net/note/edit/74677
Del: integrated -- https://master.php.net/note/delete/74677/integrated
Del: useless -- https://master.php.net/note/delete/74677/useless
Del: bad code -- https://master.php.net/note/delete/74677/bad+code
Del: spam -- https://master.php.net/note/delete/74677/spam
Del: non-english -- https://master.php.net/note/delete/74677/non-english
Del: in docs -- https://master.php.net/note/delete/74677/in+docs
Del: other reasons-- https://master.php.net/note/delete/74677
Reject -- https://master.php.net/note/reject/74677
Search -- https://master.php.net/manage/user-notes.php