note 83355 added to oci8.setup

From: Date: Thu, 22 May 2008 07:59:26 +0000
Subject: note 83355 added to oci8.setup
Groups: php.notes 
Request: Send a blank email to php-notes+get-139601@lists.php.net to get a copy of this message
More about Oracle's ORA-12514 error message, if you are running php in cgi mode AND the Oracle connection parameters are defined in the tnsnames.ora file, then the various Oracle environment variables (ORACLE_HOME, TNS_ADMIN or PATH) MUST be defined in httpd.conf with SetEnv, otherwise the tnsnames.ora is not found and Oracle's Instant Client return an ORA-12514 error. This problem do not happen when php run as an Apache module or if you are using Oracle's Easy Connect syntax in the connection string. ---- Server IP: 69.147.83.197 Probable Submitter: 128.179.66.4 ---- Manual Page -- http://www.php.net/manual/en/oci8.setup.php Edit -- https://master.php.net/note/edit/83355 Del: integrated -- https://master.php.net/note/delete/83355/integrated Del: useless -- https://master.php.net/note/delete/83355/useless Del: bad code -- https://master.php.net/note/delete/83355/bad+code Del: spam -- https://master.php.net/note/delete/83355/spam Del: non-english -- https://master.php.net/note/delete/83355/non-english Del: in docs -- https://master.php.net/note/delete/83355/in+docs Del: other reasons-- https://master.php.net/note/delete/83355 Reject -- https://master.php.net/note/reject/83355 Search -- https://master.php.net/manage/user-notes.php

« previous php.notes (#139601) next »