note 86506 added to function.rawurlencode

From: Date: Wed, 22 Oct 2008 14:40:10 +0000
Subject: note 86506 added to function.rawurlencode
Groups: php.notes 
Request: Send a blank email to php-notes+get-145594@lists.php.net to get a copy of this message
phpversion()>=5.3 will compliant with RFC 3986, while phpversion()<=5.2.7RC1 is not compliant with RFC 3986. History of related RFCs: RFC 1738 section 2.2 only alphanumerics, the special characters "$-_.+!*'(),", and reserved characters used for their reserved purposes may be used unencoded within a URL. RFC 2396 section 2.3 unreserved = alphanum | mark mark = "-" | "_" | "." | "!" | "~" | "*" | "'" | "(" | ")" RFC 2732 section 3 (3) Add "[" and "]" to the set of 'reserved' characters: RFC 3986 section 2.3 unreserved = ALPHA / DIGIT / "-" / "." / "_" / "~" RFC 3987 section 2.2 unreserved = ALPHA / DIGIT / "-" / "." / "_" / "~" ---- Server IP: 61.195.146.164 Probable Submitter: 210.148.21.17 ---- Manual Page -- http://www.php.net/manual/en/function.rawurlencode.php Edit -- https://master.php.net/note/edit/86506 Del: integrated -- https://master.php.net/note/delete/86506/integrated Del: useless -- https://master.php.net/note/delete/86506/useless Del: bad code -- https://master.php.net/note/delete/86506/bad+code Del: spam -- https://master.php.net/note/delete/86506/spam Del: non-english -- https://master.php.net/note/delete/86506/non-english Del: in docs -- https://master.php.net/note/delete/86506/in+docs Del: other reasons-- https://master.php.net/note/delete/86506 Reject -- https://master.php.net/note/reject/86506 Search -- https://master.php.net/manage/user-notes.php

« previous php.notes (#145594) next »