note 14677 modified in function.ocilogon by sixd

From: Date: Mon, 05 Oct 2009 01:29:31 +0000
Subject: note 14677 modified in function.ocilogon by sixd
References: 1  Groups: php.notes 
Request: Send a blank email to php-notes+get-161284@lists.php.net to get a copy of this message
Some trouble-shooting notes:<br> When using Apache with dso support and php as a loadable module, be sure to stop/start your web server between tnsnames.ora changes (sending HUP to apache "apachectl restart" doesn't appear to flush cached connect string).<br> You'll see your changed connect strings in the listener log file.<p> TNSNAMES.ORA:<br> This is a very simple file to manage, yet can be very picky about your syntax. Simply ensure that you follow one of these two examples:<br> Legacy SID:<br> alias-or-sidname = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(Host = hostname-or-ipaddress)(Port = 1521)) (CONNECT_DATA = (SID = sidname) ) )<br> 8i SERVICE NAME:<br> hostname.domainname.com = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = hostname-or-ipaddress)(PORT = 1521)) ) (CONNECT_DATA = (SERVICE_NAME = servicename) ) )</p> Additional notes:<br> - ORA/TNS-12514 error can also be caused by listener not being started. - Ensure that httpd user (i.e. nobody) has the following in its environment (putenv is unnecessary if env is set by os via /etc/profile): $ORACLE_SID $ORACLE_HOME<br> Also, some helpful resources: - TNS Error Messages: http://www.oradoc.com/ora817/server.817/a76999/tnsus.htm#1000527 - TNS Listener logs: $ORACLE_HOME/network/log/... --was-- Some trouble-shooting notes:<br> When using Apache with dso support and php as a loadable module, be sure to stop/start your web server between tnsnames.ora changes (sending HUP to apache "apachectl restart" doesn't appear to flush cached connect string).<br> You'll see your changed connect strings in the listener log file.<p> TNSNAMES.ORA:<br> This is a very simple file to manage, yet can be very picky about your syntax. Simply ensure that you follow one of these two examples:<br> Legacy SID:<br> alias-or-sidname = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(Host = hostname-or-ipaddress)(Port = 1521)) (CONNECT_DATA = (SID = sidname) ) )<br> 8i SERVICE NAME:<br> hostname.domainname.com = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = hostname-or-ipaddress)(PORT = 1521)) ) (CONNECT_DATA = (SERVICE_NAME = servicename) ) )</p> Additional notes:<br> - ORA/TNS-12514 error can also be caused by listener not being started. - Ensure that httpd user (i.e. nobody) has the following in its environment (putenv is unnecessary if env is set by os via /etc/profile): $ORACLE_SID $ORACLE_HOME<br> Also, some helpful resources: - TNS Error Messages: http://www.oradoc.com/ora817/server.817/a76999/tnsus.htm#1000527 - TNS Listener logs: $ORACLE_HOME/network/log/... http://php.net/manual/en/function.ocilogon.php

« previous php.notes (#161284) next »