note 103199 added to function.ifx-connect
| From: | mohd dot chehab at e-medlinks dot com | Date: | Thu, 31 Mar 2011 11:57:44 +0000 |
| Subject: | note 103199 added to function.ifx-connect | ||
| Groups: | php.notes | ||
| Request: | Send a blank email to php-notes+get-178371@lists.php.net to get a copy of this message | ||
Here's a tip :
When i first installed the informix through the removing the ; at php_ifx.dll and then restarted
apache
then checking the phpinfo(); the connection wasn't established and i had this error that i have
to set the INFORMIXSERVER.
Work Frame : Windows XP,Apache 2.2.1 php 5.3 The ODBC was working fine and i could connect to the
informix server using the odbc connection
The problem is that the sql engine was on another machine with different platform.
[SOLUTION]
add an environmental variable called INFORMIXSERVER with the value of the server e.g
myInformixServer which itself has an ip 192.x.x.x
You can do that on windows by right click on my computer advanced >> environmental variables
>> add new System variable >> variable name = INFORMIXSERVER
variable value = myInformixServer
it worked like a charm
----
Server IP: 69.147.83.197
Probable Submitter: 194.126.14.100 (proxied: 93.185.80.250)
----
Manual Page -- http://www.php.net/manual/en/function.ifx-connect.php
Edit -- https://master.php.net/note/edit/103199
Del: integrated -- https://master.php.net/note/delete/103199/integrated
Del: useless -- https://master.php.net/note/delete/103199/useless
Del: bad code -- https://master.php.net/note/delete/103199/bad+code
Del: spam -- https://master.php.net/note/delete/103199/spam
Del: non-english -- https://master.php.net/note/delete/103199/non-english
Del: in docs -- https://master.php.net/note/delete/103199/in+docs
Del: other reasons-- https://master.php.net/note/delete/103199
Reject -- https://master.php.net/note/reject/103199
Search -- https://master.php.net/manage/user-notes.php