note 113756 deleted from language.oop5.magic by peehaa
| From: | peehaa@php.net | Date: | Mon, 02 Dec 2013 09:25:55 +0000 |
| Subject: | note 113756 deleted from language.oop5.magic by peehaa | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-197710@lists.php.net to get a copy of this message | ||
Note Submitter: m_lajos at hotmail dot com
----
__set_state should be __setState, so it would look consistent compared to other multi-phrase magic
method names, like __callStatic, or __toString.
Also, I would suggest __wakeup to be renamed to __wakeUp.