note 118595 added to function.gzdeflate
| From: | HUjuice | Date: | Tue, 05 Jan 2016 17:23:47 +0000 |
| Subject: | note 118595 added to function.gzdeflate | ||
| Groups: | php.notes | ||
| Request: | Send a blank email to php-notes+get-204598@lists.php.net to get a copy of this message | ||
The HTTP deflate is quite complicated.
The RFC7230, Sec 4.2.2 (https://tools.ietf.org/html/rfc7230#section-4.2.2) says:
«The "deflate" coding is a "zlib" data format [RFC1950] containing a
"deflate" compressed data stream [RFC1951] that uses a combination of the Lempel-Ziv
(LZ77) compression algorithm and Huffman coding.»
and, also:
«Note: Some non-conformant implementations send the "deflate" compressed data without
the zlib wrapper.»
Since this function implements the RFC1951, the compliant encoding of a $payload should be:
gzcompress(gzdeflate($payload));
----
Server IP: 72.52.91.14
Probable Submitter: 78.134.3.33
----
Manual Page -- http://php.net/manual/en/function.gzdeflate.php
Edit -- https://master.php.net/note/edit/118595
Del: integrated -- https://master.php.net/note/delete/118595/integrated
Del: useless -- https://master.php.net/note/delete/118595/useless
Del: bad code -- https://master.php.net/note/delete/118595/bad+code
Del: spam -- https://master.php.net/note/delete/118595/spam
Del: non-english -- https://master.php.net/note/delete/118595/non-english
Del: in docs -- https://master.php.net/note/delete/118595/in+docs
Del: other reasons-- https://master.php.net/note/delete/118595
Reject -- https://master.php.net/note/reject/118595
Search -- https://master.php.net/manage/user-notes.php