note 41722 deleted from install.windows.iis by cmb
| From: | cmb@php.net | Date: | Sat, 04 May 2019 13:30:07 +0000 |
| Subject: | note 41722 deleted from install.windows.iis by cmb | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-210936@lists.php.net to get a copy of this message | ||
Note Submitter: tstirrat AT optusnet DOT com DT au
----
I am running Active Directory & IIS6.0
I found that after looking through the tutorial below i was still unable to get into my site
(authentication popup, 401.3 error). I set my permissions for read & execute for IUSR_(server)
and IIS_WPG for both my document root and the php directory.. no luck.
However, here's how i solved the problem. (I believe this solution is relevant to fixing the
active directory issue)
1. You want to give the IUSR_* and IIS_WPG read & execute permission to the PHP DIRECTORY ONLY.
(I managed to remove the credentials from my document root and it still works.
2. Open IIS Manager and go to Application Pools, then to the pool which is relevant to your site (in
my case DefaultAppPool).. on this item, right click and choose properties.
3. Now navigate to the identity tab.
4. My Worker process was set to Predefined: Network Service. I changed this to Configurable:
IWAM_(server name) (which if you noticed is in the user group 'IIS_WPG')
Note: i also changed the passwords for my IUSR_* and IWAM_* accounts to be sure they werent set to
something easy by default. Its probably a good idea to do this too.
Hope this solves someones frustration.