note 12700 deleted from function.extract by jimw
| From: | jimw@php.net | Date: | Sat, 08 Dec 2001 19:57:53 +0000 |
| Subject: | note 12700 deleted from function.extract by jimw | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-22153@lists.php.net to get a copy of this message | ||
You say:
> I totally agree. For small scripts. However, if you are doing 2 or 3 (or more)
> queries on a script and printing the results, it's much easier to follow the
> flow by using the $array[field_name] method as opposed to using extract()
> and $field_name method.
You can always do:
extract($array, EXTR_PREFIX_SAME, "array");
So you can have $array_fieldname instead of $array[fieldname] which is easier to print out etc.