note 19721 added to install.linux

From: Date: Fri, 08 Mar 2002 20:36:36 +0000
Subject: note 19721 added to install.linux
Groups: php.notes 
Request: Send a blank email to php-notes+get-27522@lists.php.net to get a copy of this message
I was getting an error after installing PHP and trying to restart Apache: "Cannot load /usr/local/apache_1.3.12/libexec/libphp4.so into server: undefined symbol: uncompress" Apparently this has something do with compiling with mySQL support and libz.so. The easiest way I found to correct this was to edit the Makefile after configuring. In the section that looks similar to: LTLIBRARY_LDFLAGS = -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATS) Add -lz to the beginning, so it looks like: LTLIBRARY_LDFLAGS = -lz -rpath $(phptempdir) $(EXTRA_LDFLAGS) $(LDFLAGS) $(PHP_RPATHS) Then make, make install, and restart apache. -- http://www.php.net/manual/en/install.linux.php http://master.php.net/manage/user-notes.php?action=edit+19721 http://master.php.net/manage/user-notes.php?action=delete+19721 http://master.php.net/manage/user-notes.php?action=reject+19721

« previous php.notes (#27522) next »