note 22725 added to ref.pfpro

From: Date: Thu, 27 Jun 2002 16:53:41 +0000
Subject: note 22725 added to ref.pfpro
Groups: php.notes 
Request: Send a blank email to php-notes+get-32282@lists.php.net to get a copy of this message
From Verisign's VPS support: The Payflow Pro support in PHP must be configured/compiled as a shared object. In order to enable Payflow Pro support in PHP as a shared object, pass the following switch to the PHP ./configure script: [root@localhost] # ./configure --with-pfpro=shared,/path/to/pfpro The directory specified by /path/to/pfpro must contain *both* the libpfpro.so and pfpro.h files included in the Payflow Pro SDK (usually in the lib/ and/or bin/ subdirectories of the SDK), or the ./configure step will fail. Versions of PHP prior to 4.0.2 did not contain the pfpro support functions. See http://www.php.net/downloads.php for the latest stable version of PHP. It appears to be impossible to use older versions of Apache in this sort of setup. Version 1.3.12 or greater are known to work, 1.3.9 may work, older versions reportedly do not work. See http://www.apache.org/dist/httpd/ for the latest stable version of Apache. The version of mod_ssl is closely tied to the version of Apache being used; there are sometimes multiple versions of mod_ssl available for a single version of Apache. See http://www.modssl.org/source/ for the latest version of mod_ssl. -- http://www.php.net/manual/en/ref.pfpro.php http://master.php.net/manage/user-notes.php?action=edit+22725 http://master.php.net/manage/user-notes.php?action=delete+22725 http://master.php.net/manage/user-notes.php?action=reject+22725

« previous php.notes (#32282) next »