note 25030 added to function.date
| From: | php-general at lists dot php dot net | Date: | Sun, 08 Sep 2002 14:11:02 +0000 |
| Subject: | note 25030 added to function.date | ||
| Groups: | php.notes | ||
| Request: | Send a blank email to php-notes+get-36341@lists.php.net to get a copy of this message | ||
In HTTP Headers, the HTTP/1.1 specification mandates the use of the RFC1123 format for dates:
'D, d M Y H:i:s \G\M\T'
For example:
Sun, 06 Nov 1994 08:49:37 GMT
(RFC 822, updated by RFC 1123)
See RFC2616, Section 3.3.1 "Full Date", page 19.
Do not use date() but gmdate() to create such formats, using GMT date and time:
header('Date: ' . gmdate('D, d M Y H:i:s \G\M\T'));
header(Last-Modified: ' . gmdate('D, d M Y H:i:s \G\M\T'));
--
http://www.php.net/manual/en/function.date.php
http://master.php.net/manage/user-notes.php?action=edit+25030
http://master.php.net/manage/user-notes.php?action=delete+25030
http://master.php.net/manage/user-notes.php?action=reject+25030