note 26278 added to security.registerglobals
| From: | nhallman at rack1 dot php dot net | Date: | Thu, 24 Oct 2002 19:51:29 +0000 |
| Subject: | note 26278 added to security.registerglobals | ||
| Groups: | php.notes | ||
| Request: | Send a blank email to php-notes+get-38518@lists.php.net to get a copy of this message | ||
It's possible to set register_globals to "off" on a site-by-site basis via Apache,
thus overriding the "global" setting of register_globals in php.ini:
In httpd.conf:
<VirtualHost 127.0.0.1>
ServerName localhost
DocumentRoot /var/www/html/mysite
php_value register_globals 0 (or 1 for "on")
</VirtualHost>
That way, sites with old code can have register globals turned on, but for all new developments it
will be disabled.
--
http://www.php.net/manual/en/security.registerglobals.php
http://master.php.net/manage/user-notes.php?action=edit+26278
http://master.php.net/manage/user-notes.php?action=delete+26278
http://master.php.net/manage/user-notes.php?action=reject+26278