note 27347 added to ref.ldap

From: Date: Mon, 02 Dec 2002 21:50:12 +0000
Subject: note 27347 added to ref.ldap
Groups: php.notes 
Request: Send a blank email to php-notes+get-40279@lists.php.net to get a copy of this message
When enabling ldap support for win32 binaries I ran into a few difficulties. As previously mentioned here, the libsasl library is required for php_ldap. Here are the two simple steps to getting this to work. 1. After sucessfully installing php and testing, copy the file libsasl.dll (google it for download sites, it's 40kb) to: C:/your_php_path/dlls. 2. Edit your php.ini and un-comment the line ;extension=php_ldap.dll so that it reads extension=php_ldap.dll Thats it. Restart your webserver and test with <?php phpinfo();?>. Note: if you have been fiddling with the location of libsasl.dll and you have an error "Unable to load dynamic library..." then you will need to kill the hung apache process (you can use taskinfo app for this) or restart you windows box after restoring you php.ini to original (no ldap_support). I know this sounds confusing but it is the reason why I just wasted an hour and a half. I have tested this with all php versions from 4.1.2 up incl 4.3rc2. Also have this running with apache2. We use it with the xaraya.com cms to authenticate our intranet users. Hope this saves some-one the hour and a half of pain it served me... -- http://www.php.net/manual/en/ref.ldap.php http://master.php.net/manage/user-notes.php?action=edit+27347 http://master.php.net/manage/user-notes.php?action=delete+27347 http://master.php.net/manage/user-notes.php?action=reject+27347

« previous php.notes (#40279) next »