note 28786 deleted from install.openbsd by victor
| From: | victor@php.net | Date: | Fri, 24 Jan 2003 07:46:24 +0000 |
| Subject: | note 28786 deleted from install.openbsd by victor | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-42682@lists.php.net to get a copy of this message | ||
OpenBSD 3.2 (GENERIC stable)
Working from pkg_add for the php4-core packages, httpd produces Memory Fault core dumps when
invoked.
Removal of the libphp4.so link in httpd.conf allows httpd to not core dump, and to run normally.
Now, replace the link line in httpd.conf to the libphp4.so library, and remove the actual file
libphp4.so, and you get the error:
Syntax error on line 196 of /var/www/conf/httpd.conf:
Cannot load /usr/lib/apache/modules/libphp4.so into server: No such file or directory
replacing this file with stock file does not help, return to core dump error.
I've downloaded and re-downloaded php4 packages to no avail, and nothing seems to resolve this
issue.
creating /var/www/tmp and setting ownerships/permissions appropriately did not help to resolve this
issue, I believe something in libphp4.so to be causing an error based on the fact that httpd is
chrooted.
-jre