note 28475 deleted from ref.ingres by sniper

From: Date: Tue, 27 May 2003 22:44:03 +0000
Subject: note 28475 deleted from ref.ingres by sniper
References: 1  Groups: php.notes 
Request: Send a blank email to php-notes+get-49122@lists.php.net to get a copy of this message
Note Submitter: the above burckhardt@see.posting ---- I've had a major headache compiling PHP4 with ingres support. I installed the ingres 2.6 network client on my SUSE 8.1 linux-box (the db is on another computer) and php comlained about a missing "lingres". installing the "embedded sql" component from the install CD solved this. Then configure went fine, but make did a weird "pthread-mutex" error, which was solved after adding "-lpthread" to the Makefile at the extra libs part. This has to be done after running config and before make. Then php did not want to be installed unless II_SYSTEM was set (kinda obvious). Finally, after adding "II_SYSTEM=<youringresinstallation> export II_SYSTEM" to the apachectl script and starting the ingres netserver, I am still getting errors: PHP cannot connect to the Ingres database. I get "unable to authenticate client's user id" instead. This is despite the nodes testing fine in netutil. I hope you have more luck getting this +*#%! DB running on PHP

« previous php.notes (#49122) next »