note 39719 rejected from faq.installation by irchtml
| From: | irchtml@php.net | Date: | Sun, 08 Feb 2004 19:25:04 +0000 |
| Subject: | note 39719 rejected from faq.installation by irchtml | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-64838@lists.php.net to get a copy of this message | ||
Note Submitter: michael@newobjects.com
----
Hi to all! It seems that the windows version of PHP (CGI) ignores the PHP_DOCUMENT_ROOT environment
variable and the only way to deal with this i in the ini file. I am trying to run PHP under my
product ALP (which is pseude WEB server - runs WEB apps in the Internet Explorer locally) and if the
doc_root is specified everything is ok, but this is not suitable for autorun CDs where the path can
be determined only dynamically on the user's PC. If there is another way - such as command line
parameter it will do (I searched the source code but seems most of the command line parameters are
for console mode and not for the CGI mode).