note 40944 modified in install.iis by didou
| From: | didou@php.net | Date: | Sun, 28 Mar 2004 13:25:25 +0000 |
| Subject: | note 40944 modified in install.iis by didou | ||
| References: | 1 | Groups: | php.notes |
| Request: | Send a blank email to php-notes+get-67278@lists.php.net to get a copy of this message | ||
IIS 6.0, PHP 4.3.4, Active Directory, Windows 2003 Premium
Followed this and many other manual installation guides for a manual install of PHP...
This made things super easy and was like reading a picture book for IIS6 and PHP installation:
http://s92192454.onlinehome.us./PHP_on_windows_under_IIS.html
You may want to use it to confirm your manual setup...
BUT continued to get 401.3 error...
Problem is that the 401.3 ACL error is because you must apply the IUSR_(server) access rights to the
PHP directory and all the sub-directory structures (done in the advanced tab of your security
settings), READ/LIST/EXC...
ACL 401.3 Problem solved... from other posts that I found, if you upgrade to Active Directory you
will also loose all PHP access and this should solve that problem also. The upgrade to Active
Directory problem is also known as prompting you for a username and password.
This is an option, if you choose to use the Interactive Windows Auth mode for your web site (that
too can be disabled in the IIS 6.0 configuration for each web site), but will still result in the
401.3 unless you add the IIS_WPG rights to your PHP Dir.
Hope that helps,
John Draggi
--was--
IIS 6.0, PHP 4.3.4, Active Directory, Windows 2003 Premium
Followed this and many other manual installation guides for a manual install of PHP...
This made things super easy and was like reading a picture book for IIS6 and PHP installation:
http://s92192454.onlinehome.us./PHP_on_windows_under_IIS.html
You may want to use it to confirm your manual setup...
BUT continued to get 401.3 error...
Problem is that the 401.3 ACL error is because you must apply the IIS_WPG (IIS Worker Process Group)
access rights to the PHP directory and all the sub-directory structures (done in the advanced tab of
your security settings), READ/LIST/EXC...
ACL 401.3 Problem solved... from other posts that I found, if you upgrade to Active Directory you
will also loose all PHP access and this should solve that problem also. The upgrade to Active
Directory problem is also known as prompting you for a username and password.
This is an option, if you choose to use the Interactive Windows Auth mode for your web site (that
too can be disabled in the IIS 6.0 configuration for each web site), but will still result in the
401.3 unless you add the IIS_WPG rights to your PHP Dir.
Hope that helps,
John Draggi
http://www.php.net/manual/en/install.iis.php