note 44632 added to install.iis

From: Date: Wed, 11 Aug 2004 14:02:41 +0000
Subject: note 44632 added to install.iis
Groups: php.notes 
Request: Send a blank email to php-notes+get-74439@lists.php.net to get a copy of this message
*Canon in D plays* Hi, my name is Matrix and I'm a recovering 401.3 ACL Error victim. After 3 days of agony, I found the root cause of my 401.3 ACL errors--which only occured when trying to browse a .php page yet the .htm pages came up fine. I'm running IIS 6.0 and PHP 4.3.8 on Windows Server 2003 Standard. Believe it or not, the problem was the permissions on the c:\windows\system32\php4ts.dll file only included SYSTEM and Administrators while the Users group was strangely absent. The Users group contains only INTERACTIVE and Authenticated Users. I could not use the below changes to the Application Pool as the default pool was the only one present. At home, I had installed the evaluation copy of WS2k3 along with IIS 6.0 and PHP 4.3.8 (using the convenient instructions down several comments) and it worked straight away! Thus, I was convinced that it had to be a PHP related issue and meticulously compared all effective permissions for c:\php , c:\windows\php.ini and finally c:\windows\system32\php4ts.dll. Why the permissions were different on the production system at work vs the evaluation system at home--I have no clue. Best of luck. If this helps just one other person maintain their sanity (as much as a sysadmin can have), then I'll be a happy camper. ---- Manual Page -- http://www.php.net/manual/en/install.iis.php Edit -- http://master.php.net/manage/user-notes.php?action=edit+44632 Delete -- http://master.php.net/manage/user-notes.php?action=delete+44632&report=yes Reject -- http://master.php.net/manage/user-notes.php?action=reject+44632&report=yes Search -- http://master.php.net/manage/user-notes.php

« previous php.notes (#74439) next »