note 48015 added to function.odbc-longreadlen

From: Date: Thu, 09 Dec 2004 05:37:49 +0000
Subject: note 48015 added to function.odbc-longreadlen
Groups: php.notes 
Request: Send a blank email to php-notes+get-81567@lists.php.net to get a copy of this message
I was reading from a MEMO field (long varchar) in MSAccess, but the data was consistently truncated at 255 characters. I tried all the combinations of odbc_longreadlen() and odbc_binmode() (and odbc.defaultlrl) that I could think of but none of them resolved the problem. The only fix that worked was to modify my query from "SELECT Field1, Field2 FROM TableName" to "SELECT * FROM TableName". I suspect that you could cast the field to force the appropriate data type, but when it finally worked after three days of struggle I didn't even try. ---- Manual Page -- http://www.php.net/manual/en/function.odbc-longreadlen.php Edit -- http://master.php.net/manage/user-notes.php?action=edit+48015 Delete -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes Reason: bad code -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes&reason=bad+code Reason: spam -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes&reason=spam Reason: useless example -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes&reason=useless+example Reason: contains commercial links -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes&reason=contains+commercial+links Reason: useless note -- http://master.php.net/manage/user-notes.php?action=delete+48015&report=yes&reason=useless+note Reject -- http://master.php.net/manage/user-notes.php?action=reject+48015&report=yes Search -- http://master.php.net/manage/user-notes.php

« previous php.notes (#81567) next »