Req #21252 [Com]: composer.json require pear

From: Date: Fri, 03 Nov 2017 21:19:24 +0000
Subject: Req #21252 [Com]: composer.json require pear
References: 1  Groups: php.pear.bugs 
Request: Send a blank email to pear-bugs+get-11409@lists.php.net to get a copy of this message
Edit report at https://pear.php.net/bugs/bug.php?id=21252&edit=1 ID: 21252 Comment by: mesa57 at hotmail dot com Reported By: mesa57 at hotmail dot com Summary: composer.json require pear Status: Wont fix Type: Feature/Change Request Package: Net_NNTP Operating System: Win 7 Package Version: 1.5.2 PHP Version: HEAD SVN-2017-10-23 Roadmap Versions: New Comment: No, it was more a question. I have forked net_nntp and created a composer relation to pear_core_minimal 1.10.3 or higher. I thought that choosing a lower version maybe did not support php 7.1 Is it ok if I include >= 1.10.3 ? Previous Comments: ------------------------------------------------------------------------ [2017-11-03 09:10:58] heino -Status: Assigned +Status: Wont fix The package is tested via travis-ci.org, and passes the tests against PHP v5.4, v5.5, v5.6, v7.0 and v7.1, so how does It not support these versions? If your question relates the the pear-core-minimal package, I believe the answer were already provided in the previous reply... ------------------------------------------------------------------------ [2017-11-03 05:12:57] mesa57 What would be the requirements if we want the package to support php 5.4 till 7.1 ? ------------------------------------------------------------------------ [2017-10-23 18:10:32] heino I recognize your point, however I am not sure if using different requirements in package.xml and composer.json is acceptable. I am not aware of current PEAR guidelines on this subject. Also changing the requirement to pear-core-minimal would require upgrading the minimal version from 1.4.x to 1.9.5, since this is the first version tagged in the pear-core-minimal repository. I have not looked into possible backward compatibility break between these versions. I currently do not have time for such non-bug optimizations of this legacy code. However, if you provide a working pull request for a v1.6 branch (with proper updates to both package.xml and composer.json), I will of cause roll a release. Since the package currently requires php v5.0, pear- core-minimal should not require anything beyond v1.9.x. ------------------------------------------------------------------------ [2017-10-23 17:43:16] heino -Assigned To: +Assigned To: heino ------------------------------------------------------------------------ [2017-10-23 15:13:54] mesa57 Description: ------------ The composer file requires pear which drags in almost 1800 files ! The package pear-core-minimal is enough for net_nntp. Please change the composer.json require. ------------------------------------------------------------------------ -- Edit this bug report at https://pear.php.net/bugs/bug.php?id=21252&edit=1

« previous php.pear.bugs (#11409) next »