Req #11209 [Opn->Ana]: Make options's visibility protected
| From: | borz_off at cs dot msu dot su | Date: | Fri, 03 Apr 2009 17:46:51 +0000 |
| Subject: | Req #11209 [Opn->Ana]: Make options's visibility protected | ||
| References: | 1 | Groups: | php.pear.bugs |
| Request: | Send a blank email to pear-bugs+get-298@lists.php.net to get a copy of this message | ||
Edit report at http://pear.php.net/bugs/bug.php?id=11209&edit=1
ID: 11209
Updated by: borz_off@cs.msu.su
Reported By: wiesemann at php dot net
Summary: Make options's visibility protected
-Status: Open
+Status: Analyzed
Type: Feature/Change Request
Package: HTML_Common2
Operating System: Irrelevant
Package Version: 2.0.0beta1
PHP Version: 5.2.2
Roadmap Versions:
New Comment:
-Status: Open
+Status: Analyzed
Looks like we already have protected $options in
HTML_QuickForm2_Element_Select_OptionContainer, so it won't be a good
idea to make the field protected in HTML_Common2
On the other hand, I can change getOption() to just return the array of
options if no $name is given. That'll be enough, I suppose.
Previous Comments:
------------------------------------------------------------------------
[2007-07-06 05:07:35] mansion
I wouldn't mind having getIndent() a public method as well.
------------------------------------------------------------------------
[2007-06-02 16:39:57] wiesemann
Description:
------------
I'd like to get away from several setter/getter methods in HTML_Table2.
Instead of e.g. having methods setAutoGrow()/getAutoGrow(), it would be
nice to use the $_options array. This would allow me to pass values (not
'autoGrow', but e.g. 'autoFill') to the various instances of the storage
class.
Would you be willing to rename $_options to $options and to mark is as
protected? (A protected getOptions() method would be another solution.)
Multiple getOption() calls don't seem like a clean solution to me.
------------------------------------------------------------------------
--
Edit this bug report at http://pear.php.net/bugs/bug.php?id=11209&edit=1