Re: cvs: php4 /pear/DB common.php
| From: | Stig S. Bakken | Date: | Mon, 26 Nov 2001 09:30:06 +0000 |
| Subject: | Re: cvs: php4 /pear/DB common.php | ||
| References: | 1 2 3 | Groups: | php.pear.cvs |
| Request: | Send a blank email to pear-cvs+get-1405@lists.php.net to get a copy of this message | ||
"Tomas V.V.Cox" wrote:
>
> "Stig S. Bakken" wrote:
> >
> > Perl DBI uses do() for this. I think we should adopt that, for less
> > typing. :-)
> >
>
> When change the name from excuteQuery() to do() I get:
> <br>
> <b>Parse error</b>: parse error, expecting `T_STRING' in
> <b>/root/cdrom/download/php4/pear/DB/common.php</b> on line
> <b>445</b><br>
> <br>
>
> A reserved word conflict? what about doQuery()?
*DOH* :-)
Actually, why can't DB_common::query just accept an optional second
parameter? If the parameter is an array, the query is prepared and
executed with the second parameter as execute data?
- Stig