Re: cvs: php4 /pear CODING_STANDARDS
| From: | Tomas V.V.Cox | Date: | Wed, 15 Aug 2001 21:30:48 +0000 |
| Subject: | Re: cvs: php4 /pear CODING_STANDARDS | ||
| References: | 1 | Groups: | php.pear.cvs |
| Request: | Send a blank email to pear-cvs+get-539@lists.php.net to get a copy of this message | ||
Stig Bakken wrote:
>
> ssb Wed Aug 15 17:03:53 2001 EDT
>
> Modified files:
> /php4/pear CODING_STANDARDS
> Log:
> * point people to the manual instead
>
>
This isn't in the manual (haven't check other parts):
-Functions should be named using the "studly caps" style (also referred
to as
-"bumpy case" or "camel caps"). The initial letter of the name is
lowercase,
-and each letter that starts a new "word" is capitalized. Some
examples:
-
- connect() getData() buildSomeWidget()
-
-Private class members (meaning class members that an intented to be
used
-only from within the same class in which they are declared; PHP does
not yet
-support truly-enforceable private namespaces) are preceeded by a single
-underscore. For example:
-
- _sort() _initTree() $_status
Tomas V.V.Cox