Re: Net_IMAP Class Status Update

From: Date: Sat, 22 Feb 2003 00:35:26 +0000
Subject: Re: Net_IMAP Class Status Update
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-13613@lists.php.net to get a copy of this message
Damian Alejandro Fernandez Sosa(damlists@cnba.uba.ar)@Wed, Feb 19, 2003 at 09:43:20PM -0300: > I worked a lot in the Net_IMAP class now it does: > > * You can choose to expunge or not the emails on exit (logout method) > * The commands (and its names) now are PEAR Compatible > * Returned PEAR_Error when posible (HIGH LEVEL API) > * Added Peardoc sytle comments > * Implemmented a generic parser that parses all the IMAP responses (even > the known extensions to RFC2060!) > * Implemmented RFC2086 "IMAP4 ACL extension" all commands and responses: > SETACL,DELETEACL,GETACL,LISTRIGHTS,MYRIGHTS > * Implemmented RFC2087 "IMAP4 QUOTA extension" all commands: > SETQUOTA,SETQUOTAROOT,GETQUOTA,GETQUOTAROOT > > please take a look, go to: > > http://fernandezsosa.com.ar/Net_IMAP/IMAP.phps (high level API > 80% done > (fully functional)) > http://fernandezsosa.com.ar/Net_IMAP/IMAPProtocol.phps (low > level API > 95% done (fully functional)) > http://fernandezsosa.com.ar/Net_IMAP/test1.phps (HIGH LEVEL API > example) > http://fernandezsosa.com.ar/Net_IMAP/test2.phps (LOW LEVEL API > example) > > > Comments,Ideas, +1? I would like to merge my IMAP_Admin and IMAP_Simple class to Net_IMAP class, so +1. -az

« previous php.pear.dev (#13613) next »