Re: Re: PDBPLUS: cannot redefine g()
| From: | CHAILLAN Nicolas | Date: | Thu, 31 Jul 2003 19:48:12 +0000 |
| Subject: | Re: Re: PDBPLUS: cannot redefine g() | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-19074@lists.php.net to get a copy of this message | ||
"Ondrej Jombik" <nepto@pobox.sk> a écrit dans le message de
news:Pine.LNX.4.44.0307312122170.28742-100000@pauli.fmph.uniba.sk...
> On Thu, 31 Jul 2003, Greg Beaver wrote:
>
> > Yes, you should rename G(). This is not great programming practice
> > even if it is legal, the potential for missed typos is huge.
>
> This was not actually what I was asking for.
>
> For explanation: this convention in this SPECIAL purpose was
> estabilished by Thomas. In PDBPLUS you are entering commands in \l
> notation, where 'l' some action letter. According to this letter, loader
> searches for particular method and runs it.
>
> I consider this approach as good.
>
> So once again: are PHP function case-insensitive in version PHP/4.3.2?
No, class and functions names created in userland are not sensitive.
>
> --
> _/| Ondrej Jombik - nepto@php.net - http://www.nepto.sk -
> OJ812-RIPE
> <_ \ Platon SDG - open source software development -
> http://platon.sk
> `\| UNIX is user friendly. It's selective about who its friends are!
> '`
>