Re: Package/Class naming conventions in PEAR

From: Date: Tue, 10 Apr 2001 21:38:42 +0000
Subject: Re: Package/Class naming conventions in PEAR
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-201@lists.php.net to get a copy of this message
I went ahead and renamed the classes and updated the examples and docs accordingly. Also, I think that the commints to the "pear" dir on cvs.php.net should be send to the pear-dev list, same as the "phpdoc" ones go to the phpdoc list. This will avoid the confusion that people at the php-cvs list might have with this part of PEAR. I can update the "CODING_STANDARDS" file to make this issue of naming conventions more clear, if nobody objects to that. --- Chuck Hagenbuch <chuck@horde.org> wrote: > Quoting "Jesus M. Castagnetto" > <jcastagnetto@yahoo.com>: > > > Should we also enforce that the classes are name > > accordingly? (I am not following this in the > package I > > just commited). What I mean is that if we have the > > "Atom" class in the aforementioned package, > perhaps I > > should be using: Science_Chemistry_Atom instead of > > Chem_Atom as the class name. > > Yes. (Science_Chemistry_Atom). Until we have > namespaces. ===== --- Jesus M. Castagnetto (jcastagnetto@yahoo.com) __________________________________________________ Do You Yahoo!? Get email at your own domain with Yahoo! Mail. http://personal.mail.yahoo.com/

« previous php.pear.dev (#201) next »