Re: Feature additions to DB_DataObject_FormBuilder

From: Date: Tue, 02 Dec 2003 09:49:41 +0000
Subject: Re: Feature additions to DB_DataObject_FormBuilder
References: 1 2 3 4 5  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-24044@lists.php.net to get a copy of this message
Alan Knowles wrote:
It would be very nice to have a discussion on the naming conventions of configuration options of the DB_DataObject and DB_DataObject_FormBuilder packages. FormBuilder options placed in DataObject classes (fieldLabels, for example) should have a prefix to avoid confusion (imagine a table with a field called "fieldLabels"). Some config options have underscores in their names (e.g. hide_primary_key) while others have another naming convention (createSubmit). At the same time, a discussion would be great about placement of configuration options.
It jumps into the realm of Backward Compatibility a bit.. - at present most/all of the config options in the ini file use '_' seperators, rather than studlyCaps.
Actually, I've been a little unhappy with the inconsistency in the naming of the config options myself. The only reason why I didn't change them yet is because of BC. The package is not yet 1.0 though, so theoretically such a change can still be introduced (although it would be somewhat painful for me, as I use this in an application with almost 100 tables which has been deployed several times... brr, really don't wanna go through all of this code if I don't have to :-)). But as always, if the majority of people think the current naming stinks, I'll change it. CU Markus

« previous php.pear.dev (#24044) next »