[Fwd: Re: [PEAR-QA] richy and tal's packages]

From: Date: Wed, 28 Apr 2004 19:23:27 +0000
Subject: [Fwd: Re: [PEAR-QA] richy and tal's packages]
Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-28506@lists.php.net to get a copy of this message
this discussion better fits here -------- Original Message -------- Subject: Re: [PEAR-QA] richy and tal's packages Date: Wed, 28 Apr 2004 19:10:55 +0200 From: Arnaud Limbourg <arnaud@limbourg.com>
Whoever does take it, PEAR desperately needs a OO-based File class instead of the current static method collections (File2? File_Object?). Directory_Lister or something along those linse might be a better name. Anyways, if it is a different competing package, does anyone see a problem with that? Josh and I have been talking about writing such a beast to replace the Io class in phpDocumentor - it would also be used in PEAR_PackageFileManager, and by any project that needs the ability to selectively list files with ignore/inclusion by wildcards.
I remember Richard once mentionning they should have gone that way, instead of static methods ;) Anyway, I think it would be a great addition to PEAR. Arnaud. -- PEAR QA Mailing List (http://pear.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php -- Lukas Smith smith@backendmedia.com _______________________________ BackendMedia www.backendmedia.com berlin@backendmedia.com Linn Zwoch Smith GbR Pariser Str. 44 D-10707 Berlin Tel +49 30 83 22 50 00 Fax +49 30 83 22 50 07

« previous php.pear.dev (#28506) next »