I thought the first step was to discuss about the package on the mailing-list.
Yeah - things are a bit vauge on that.. - Things like this that are very 'distinct' are pretty easy to go straight to proposals..
* case xxx: action;action;break; - should be on seperate lines..
For the very long constant switches, it makes it hardly less readable.
But if it absolutely have to, I will reformate those, in which case using constant() would perhaps be preferable.
Alot of those look like they could be made more generic..
The big commands case, could do something like:
array(
'resize' => array('x','y')
.......
),
.. then do a simple call_user_func_args()..
* method names studly caps
Even for private ones?
Notice that all are private, since the interface is XML.
The only one user should call is :
$msl_parser = new MSL_Parser;
$msl_parser->Parse($msl_content);
most of them should be _prefixed if private - AFAIK there are not solid rules on private methods (and some of my old classes use under_score methods for privates). It kind of goes against the spirit of the Coding standards to be too selective.
* eventually plan to break it up into 1file/class.. (if we ever get
there with that RFC..)
Ok I can plan it adding this in the todo list, but I won't be able to do this work in only one week, like the other changes/corrections.
I;m quite keen to see this as a condition for stable packages only - as I can see it is quite usefull for development to work in a single file while exporing ideas.
I'm not presonally sure on the wisdom of creating a scripting language
in XML..
Yeap - It works ok for simple recording of actions, but if you have to script something complex, being able to generate PHP would be far more usefull.. :) .. perhaps a Conjure to PHP script generator would be pretty amazing..
I guess this comes from experience, XML is very powerfull for transfering data from one Computer system to another, in a neutral format, and having the ability to read, and make minor modifications. - but it is labourious and difficult to read for complex systems, that need alot of user modification.
Regards
Alan