Re: [PEPr] +1 for Networking::Net_SMS

From: Date: Fri, 07 May 2004 11:11:29 +0000
Subject: Re: [PEPr] +1 for Networking::Net_SMS
References: 1 2 3  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-28948@lists.php.net to get a copy of this message
Chuck Hagenbuch wrote:
Quoting Tobias Schlitt <toby@php.net>:
Should both be Net_SMS_Clickatell_Http instead of Net_SMS_clickatell_http.
Uh, why? That just makes including drivers more complicated (exact case needed). -chuck -- "Regard my poor demoralized mule!" - Juan Valdez
Because of the PEAR Naming Conventions. Tobias made a proposal about naming conventions, you may have a look on it under [1]. It goes more into detail than the existing conventions in the PEAR manuals do. What about a mapping for your drivers class names? strtoupper()'ing the first character after each underscore would be a very good solution I think. Hope that idea sounds nice to you, wish a nice weekend ;-) -- David Rech [1] http://pear.php.net/pepr/pepr-proposal-show.php?id=55

« previous php.pear.dev (#28948) next »