Re: Extending "Limit" support
| From: | Tomas V.V.Cox | Date: | Mon, 26 Nov 2001 02:57:25 +0000 |
| Subject: | Re: Extending "Limit" support | ||
| References: | 1 2 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-3088@lists.php.net to get a copy of this message | ||
"Stig S. Bakken" wrote:
>
> "Tomas V.V.Cox" wrote:
> >
> > Hi,
> >
> > I've been playing with the limit support and want to make it avaible in
> > execute, getCol, getAssoc and getAll. But I'm not sure on the execute
> > thing. For ex if I add it in execute it will look like:
> >
> > $db->execute($stmt, $data, $from, $count);
> > but now query() doesn't have that params, it use limitQuery() instead
> > and perhaps will confuse people. So to unify the API I propose:
> >
> > a) Add limitExecute() and use the limit* family to do that, or:
> >
> > b) Add the extra params from/count to query() and execute() and drop
> > limitQuery(), loosing the chance of putting other coolest params in the
> > future.
> >
> > What way would you prefer?
>
> What about having a function that sets the limit for the next query?
where "next query" means: query(), execute(), executeQuery(), getAll(),
getCol() and getAssoc(). I dropped this idea because IMO it reduces the
readability, but there are too much functions for being adding extra
params to all of them, so perhaps this is not bad at all. So leave
limitQuery() for this stuff, ex:
$db->limitQuery($from, $count);
$res = $db->query($sql);
?
>Or
> simply drop limitQuery and parse the query?
>
Don't catch you here, supply the $from/$count how?
Tomas V.V.Cox