New version of FormBuilder in CVS-MAJOR BC BREAKS

From: Date: Wed, 30 Jun 2004 08:14:19 +0000
Subject: New version of FormBuilder in CVS-MAJOR BC BREAKS
Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-31363@lists.php.net to get a copy of this message
The time has come for FormBuilder to get ready to be stable and to that end, Markus, Norbert and I have been going through FormBuilder and trying to figure out what needs to be done. Bad news first. Unfortunately, not only has FormBuilder been worked on by three people with three different styles, it was also started in a non-PEAR CS conformant style and was later changed. So, because of all of that, there are many BC breaks as we have unified the naming conventions. We have also decided to remove support for the formBuilder.ini file, so if you've been using __display_fields or __order_fields, you'll need to move the options to the related DataObject file. But there is good news! First of all, I've created a script which *should* be able to convert all of your ini files and DataObject files to use the new naming conventions. It even moves the formBuilder.ini settings into your DataObject classes. :-) There's also some added functionality. Defaults for all options may now be in the DataObject.ini file, named the same as their counterparts in the FormBuilder. You can also set *any* setting in the FormBuilder from the DataObject by using a member named fb_normalName. Such as fb_createSubmitButton for createSubmitButton. Also, if you haven't checked it out, the crossLink and tripleLink functionality should be ready for testing. That's the overview. If you feel up to trying out the bleeding edge, get the files from CVS and file bugs (if you find anyway ;-): http://cvs.php.net/cvs.php/pear/DB_DataObject_FormBuilder Please read the change comment for FormBuilder.php before using it and back up your files before running the fix script. One last caveat, the selectAddEmpty option will likely be moving soon from the linked DataObject to the linking DataObject. -- paperCrane --Justin Patrin--

« previous php.pear.dev (#31363) next »