[PEPr] Comment on Images::GraPHPite

From: Date: Wed, 01 Sep 2004 09:38:36 +0000
Subject: [PEPr] Comment on Images::GraPHPite
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-33139@lists.php.net to get a copy of this message
Alan Knowles (http://pear.php.net/user/alan_k) has commented on the proposal for Images::GraPHPite. Comment: OK - a bit more thorough CS list: var $Canvas should be var $canvas (lcfirst variables) most local vars should be lcfirst (i'm not sure if it's a CS standard, but it's common practice) globals that are specific to the package should be named $_IMAGE_GRAPHITE_* or $IMAGE_GRAPHITE_* depending if they are private/public globals. you can probably put the named_colors.txt in a subdirectory and use dirname(__FILE__), rather than constants. method names should be StudlyCaps, and not "perform_antialias()" constants should be IMAGE_GRAPHITE_*, not just GRAPHITE_* The folder layout needs fixing: for example: Image_Graphite_Grid should install into Image/Graphite/Grid.php Image_Graphite_Grid_Lines should install into Image/Graphite/Grid/Lines.php require_once / includes should not have ()'s they are statements, not methods Image_GraPHPite_Parent may be better called Image_GraPHPite_Common, to be consitant with other packages. Actually make the changes 'yet' is not really a hinderence to the voting, they could be made before the first release. Looks like a pretty comprehensive package. Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=145 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#33139) next »