Re: Please comments on Image_Graph-dev1
| From: | Martin Jansen | Date: | Fri, 29 Oct 2004 07:28:37 +0000 |
| Subject: | Re: Please comments on Image_Graph-dev1 | ||
| References: | 1 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-34144@lists.php.net to get a copy of this message | ||
On Thu Oct 28, 2004 at 11:4934PM +0200, Stefan Neufeind, PEAR wrote:
> at the beginning of this week we've released a first dev-version of the
> new (!) Image_Graph, based on Graphite. And there were already 94 downloads.
>
> Could you please make up your mind about the package and the API, and
> let us know? In this step we can choose various things between various
> possible solutions. But I'd prefer the next version to be an alpha - and
> then we need the API fixed!
I only skimmed through the code quickly, but already have a few
questions:
Graph.php:
. Do you really think it is wise the always log errors into
image_graph.log? Some people may want to use another log file and
some may also want to use no file-based logging at all.
. I'd rename hideLogo() to setHideLogo(boolean)
. It seems to be common practice to use to* methods for output
redirection. In this context it may make sense to rename saveAs() to
toFile().
. done() -> get()?
I didn't have enough time to look at the gazillion other files, but I'll
probably play around with the code later.
--
- Martin Martin Jansen
http://martinjansen.com/