[PEPr] Comment on Authentication::Auth_TypeKey

From: Date: Mon, 29 May 2006 18:14:32 +0000
Subject: [PEPr] Comment on Authentication::Auth_TypeKey
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-42668@lists.php.net to get a copy of this message
Philippe Jausions (http://pear.php.net/user/jausions) has commented on the proposal for Authentication::Auth_TypeKey. Comment: Class properties shouldn't be all-caps. i.e. should be var $baseURL instead of $AUTH_TYPEKEY_BASEURL. Docblocks starts with /** not /* Create sub-classes for each math modules. i.e. one for GMP and one for BCMath. For instance Auth/TypeKey/GMP.php and Auth/TypeKey/BCMath.php. The extension to be used could be specified in the constructor. This would allow to run regression tests with both extensions. I believe GMP is faster than BCMath but do some benchmarking to determine that, so the package can use the fastest extension available. No need to extend the PEAR class. site_token() should be renamed to siteToken() Use single-quotes ' instead of double-quotes " around strings. Remove space between name of function and opening-parenthese. ie. "function Auth_TypeKey($init = array())" instead of "function Auth_TypeKey ( $init = array() )" Use PEAR::loadExtension() instead of extension_loaded() Constructor must NOT return anything. Correct indentations to 4-space, for instance in "switch" block of verifyTypeKey() Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=164 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#42668) next »