Re: PHP5 only sure .. E_STRICT?
| From: | Raphaël Gertz | Date: | Wed, 12 Jul 2006 17:37:06 +0000 |
| Subject: | Re: PHP5 only sure .. E_STRICT? | ||
| References: | 1 2 3 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-43442@lists.php.net to get a copy of this message | ||
> Le mercredi 12 juillet 2006 10:08, Lukas Smith a écrit :
> > Anyway, on production box php should be configurer like that :
> > report E_ALL
> > display error false
> > log error true
>
> I was not talking about production systems. The problem is that if you
> get flooded by E_STRICT messages you cannot fix, because you want to
> stay compatible with a previous release of the same major version you
> will go nuts during development. The filtering solution will allow you
> to more sanely work with E_STRICT.
>
Then it whould be easyer for you to build the previous release of php and load
the old libmod_php(5|4).so in apache for you devel for a previous version...
or simply run a apache with previous version in an other port and redirect
with mod_proxy the request to it...
or build the two php and overide their symbol...
(I did it, it's realy anoying, complicated and you will need to build
staticaly (no loadable modules, all build-in) and patch some features)
That way you may load all the different php version as sapi in the same
release (with different handler).
I already did it to makes run php4 and php5 on same apache as sapi, but that
kind of stuff is for sell (I spend to many time on it and miss too much money
to give it for free sry)...
Attachment: [application/pgp-signature]
Attachment: [application/pgp-signature]