Method renaming in XML_Tree/Tree.php
| From: | Martin Jansen | Date: | Fri, 08 Feb 2002 07:37:55 +0000 |
| Subject: | Method renaming in XML_Tree/Tree.php | ||
| Groups: | php.pear.dev | ||
| Request: | Send a blank email to pear-dev+get-4499@lists.php.net to get a copy of this message | ||
Guys,
the method names in PEAR's XML_Tree/Tree.php are not compliant
to the PEAR Coding Standards.
Do you object against changing the names from
add_root() -> addRoot()
etc.? The old method names could be kept as wrappers to the new ones:
function &add_root(...)
{
$this->addRoot(...);
}
- Martin
--
Martin Jansen, <mail@martin-jansen.de>
http://www.martin-jansen.de/