Re: Your opinion about QuickForm2 API
| From: | Alexey Borzov | Date: | Mon, 16 Apr 2007 11:54:40 +0000 |
| Subject: | Re: Your opinion about QuickForm2 API | ||
| References: | 1 | Groups: | php.pear.dev php.pear.general |
| Request: | Send a blank email to pear-dev+get-46236@lists.php.net to get a copy of this message | ||
Hi,
Bertrand Mansion wrote:
We are in the middle of a discussion Alexey and I about QuickForm2 API for elements creation and I would like your opinion as well. At this point, nothing is immutable since we aren't even talking about alpha stage, so your preferences as users and developers is interesting. To summarize, Alexey would be in favor of this: $form->addElement('button', 'aButton', 'Click me please'); $form->addElement('select', 'aSelect', array('1' => 'option 1', '2' => 'option 2')); While I would be in favor of this: $form->addElement('button', 'aButton')->setContent('Click me please'); $form->addElement('select', 'aSelect')->setOptions(array('1' => 'option 1', '2' => 'option 2')); This is an example for adding a button to a form. The API can get more complex for Date elements and other javascript aided elements.I'd like to clarify a bit: both of the above calls are possible right now, see the relevant elements http://cvs.php.net/viewvc.cgi/pear/HTML_QuickForm2/QuickForm2/Element/Button.php?revision=1.1&view=markup http://cvs.php.net/viewvc.cgi/pear/HTML_QuickForm2/QuickForm2/Element/Select.php?revision=1.4&view=markup So this is just an issue of personal preference, which isn't being enforced or something. What's really being discussed is the following, will we make the "additional data" parameter that has different semantics from element to element always an array, so the first pair of calls above turns into $form->addElement('button', 'aButton', array('content' => 'Click me please')); $form->addElement('select', 'aSelect', array('options' => array('1' => 'option 1', '2' => 'option 2'))); even though the elements in question will never need any additional data other than 'content' and 'options'.
My opinion is that we shouldn't mix configuration parameters for elements with other kind of data they might need. The other point we are discussing is about the extra parameter in element creation. I suggest we always use an array, even when there is only one extra parameter. Alexey suggests that we use a scalar if there is only one extra parameter. For example, for a given "Year" element which would only accept one configuration parameter 'startYear', Alexey would use: $form->addElement('year', 'aYear', '2007'); While I would use: $form->addElement('year', 'aYear', array('startYear' => '2007')); So my way is more verbose and less writable, but is also more readable and extensible. Given these examples, are there any opinions or preferences in favor of one or the other proposed API ? Thanks in advance,