[PEPr] Comment on File System::S3

From: Date: Wed, 05 Dec 2007 15:30:28 +0000
Subject: [PEPr] Comment on File System::S3
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-48683@lists.php.net to get a copy of this message
Philippe Jausions (http://pear.php.net/user/jausions) has commented on the proposal for File System::S3. Comment: This is an excellent idea! However I see the following problem: - Global var usage for error reporting, - Inconsistency in class constant names "READ_PRIV" vs. "PUB_WRITE", why not "PUBLIC_WRITE" and "PRIVATE_READ" instead? (Note that PRIV could be interpreted as either Privilege and Private leading to possible confusion in documenting, support of the package and so on...) - As noted by Chuck getMimeType() is redundant with other packages, - "or die()" at the end of the file, I'd go with letting the user register the stream through a static method of the class File_S3::register($private, $key) - Inconsistent naming of private properties "$buffer" vs. "$bufSize", go with "$bufferSize" instead - init() calling the __construct() and the $this->isConstructed checking, - __construst() doesn't actually return anything (phpDoc @return mixed) - Use of constants S3_PRIVATE and S3_KEY: 1. impossible to change the key in the same script, 2. wrong names should at least be FILE_S3_PRIVATE, FILE_S3_KEY. Use class static properties instead. - How do you pass proxy and other settings to HTTP_Request ? Proposal information: http://pear.php.net/pepr/pepr-proposal-show.php?id=519 -- Sent by PEPr, the automatic proposal system at http://pear.php.net

« previous php.pear.dev (#48683) next »