Re: services_libravatar caching
| From: | Stelian Mocanita | Date: | Sun, 28 Oct 2012 13:44:26 +0000 |
| Subject: | Re: services_libravatar caching | ||
| References: | 1 2 3 4 | Groups: | php.pear.dev |
| Request: | Send a blank email to pear-dev+get-55077@lists.php.net to get a copy of this message | ||
Changes are now in my fork, please have a look.
Stelian
On Sun, Oct 28, 2012 at 2:13 PM, Stelian Mocanita <stelianm@php.net> wrote:
> Hello Christian,
>
> Will do the required changes today.
>
> Stelian
>
>
> On Sun, Oct 28, 2012 at 8:05 AM, Christian Weiske <cweiske@cweiske.de>wrote:
>
>> Hello Stelian,
>>
>>
>> > > Did you find out where your commits vanished? Can you push them
>> > > again?
>> > >
>>
>> https://gitorious.org/~stelian/services_libravatar/stelians-services_libravatar
>> > I have no idea what happened to that commit, if I ever did push it
>> > there. I found the right snapshot of the VM hosting those changes and
>> > comited everything again and opened a pull request.
>> Awesome!
>>
>> > Please have a look at it and provide any feedback to it.
>>
>> 1. I'd like to see that you're following the PEAR Coding Standards :)
>> What I've noted:
>> - require_once instead of require, no parenthesis around the file path.
>> - missing docblocks from new methods
>> - opening { of new method needs to be on new line
>>
>> Just run PHP_CodeSniffer on it.
>>
>> 2. Another issue is tests. Are you proficient enough with PHPUnit to add
>> caching tests them? I could do that if you want.
>>
>> 3. Please move DriverCacheLite.php to Driver/CacheLite and rename the
>> class accordingly.
>>
>> 4. Please rename setCache to setDnsCache, and the variable accordingly.
>> I'd also (later) like to have image caching, which needs to be
>> separate from the DNS cache.
>>
>> --
>> Regards/Mit freundlichen Grüßen
>> Christian Weiske
>>
>> -=≡ Geeking around in the name of science since 1982 ≡=-
>>
>
>