Re: [fastCache] Name

From: Date: Tue, 23 Jul 2002 20:26:45 +0000
Subject: Re: [fastCache] Name
References: 1  Groups: php.pear.dev 
Request: Send a blank email to pear-dev+get-7927@lists.php.net to get a copy of this message
(Mika) > Humm. I think that differs a bit with the naming scheme used > earlier. Cache_Graphics caches graphics, Cache_Output caches > output of a script. > Now Cache_File denotes container (the file) and not what is > cached. Some people (including me :) might find this > misleading. > Not a big issue though. One point for you. What about Cache_InFile or better Cache_Safe (because of tests to avoid cache corruption even on NFS) ? When the name will be ok for all, I will put it on CVS. I have updated the class on my website with : - reading control (a key 'crc32' (default) is calculated and embeded in the cache) - writing control (reading and comparing the cache just after writing it) Perfs are still ok. http://www.esub2.com/pear/fastCache.php.txt Fab

« previous php.pear.dev (#7927) next »