Re: DB/DB_DataObject and MySQL character sets
| From: | Martin Braun | Date: | Tue, 14 Dec 2004 16:38:41 +0000 |
| Subject: | Re: DB/DB_DataObject and MySQL character sets | ||
| References: | 1 | Groups: | php.pear.general |
| Request: | Send a blank email to pear-general+get-16228@lists.php.net to get a copy of this message | ||
Denis Gerasimov wrote:
Hello, I use DB/DB_DataObject (latest versions) + MySQL 4.1.7 Almost every query to db fails with this message: [DB_Error: message="DB Error: unknown error" code=-1 mode=return level=notice prefix="" info="SELECT * FROM news_news WHERE status = 'PUBLISHED' ORDER BY date DESC LIMIT 8 [nativecode=1267 ** Illegal mix of collations (cp1251_general_ci,IMPLICIT) and (latin1_swedish_ci,COERCIBLE) for operation '=']"]hi, I started getting weird errors after upgrading to mySQL 4.1. are you using mysql or mysqli? which PHP version? martin -- /* no comment */ Please use my public PGP key: http://www.mbant.de/mbant-gpg-key