FormBuilder: Misleading names for some options
| From: | Michel D'HOOGE | Date: | Wed, 07 Jun 2006 12:06:46 +0000 |
| Subject: | FormBuilder: Misleading names for some options | ||
| Groups: | php.pear.general | ||
| Request: | Send a blank email to pear-general+get-24273@lists.php.net to get a copy of this message | ||
Hello,
If I have understood well, the word 'link' in FB options is used in 2
different ways. On one hand, there are 'outgoing' links. Those links use
Foreign Keys of the main DO (i.e. the one given to the FB) to link to
Primary Keys of secondary DO.
On the other hand, we have 'incoming' links. That is: what to do when a DO
is referenced by another one. For instance, linkDisplayFields and
linkOrderFields (which used to be selectDisplayFields and
selectOrderFields) are in that second case.
That said, it seems to me that linkDisplayFields should be renamed to
something else to remove ambiguity with the first kind of links. And
linkOrderFields is also used by DataGrid as the initial sorting choice.
Maybe it could be renamed to sortFields.
Finally, fieldsToRender and preDefOrder looks like being redundant to me.
They could be easily merged together.
My 2 cents
--
Michel