[ANNOUNCEMENT] HTTP_Request2-0.3.0 (alpha) Released.
| From: | PEAR Announce | Date: | Wed, 28 Jan 2009 21:22:26 +0000 |
| Subject: | [ANNOUNCEMENT] HTTP_Request2-0.3.0 (alpha) Released. | ||
| Groups: | php.pear.general | ||
| Request: | Send a blank email to pear-general+get-29656@lists.php.net to get a copy of this message | ||
The new PEAR package HTTP_Request2-0.3.0 (alpha) has been released at http://pear.php.net/.
Release notes
-------------
API changes:
* Removed HTTP_Request2::getConfigValue() method
Feature additions:
* Added digest authentication (RFC 2617) support to Socket adapter. Thanks
to Tom Snyder (tomsn at inetoffice dot com) who sent me a prototype
implementation for HTTP_Request a couple of years ago.
* Added HTTPS proxy support to Socket adapter, this works through CONNECT
request described in RFC 2817.
* Mock adapter can now throw an Exception instead of returning a response
if Exception object is added via its addResponse() method (request #15629)
Other changes and fixes:
* Support RFC 3986 by not encoding '~' in POST body (request #15368)
* Prevent an error with particular versions of PHP and Curl (bug #15617)
* Regular expressions used in HTTP_Request2 are now class constants
(request #15630)
* Curl adapter now throws an exception in case of malformed (non-HTTP)
response rather than dies with a fatal error (bug #15716)
* Curl handle wasn't closed in Curl adapter in case of error (bug #15721)
* Curl adapter sent an extra 'sentHeaders' event and returned bogus
response status when server returned 100-Continue response (bug #15785)
Package Info
------------
PHP5 rewrite of HTTP_Request package. Provides cleaner API and pluggable
Adapters. Currently available are:
* Socket adapter, based on old HTTP_Request code,
* Curl adapter, wraps around PHP's cURL extension,
* Mock adapter, to use for testing packages dependent on HTTP_Request2.
Supports POST requests with data and file uploads, basic and digest
authentication, cookies, proxies, gzip and deflate encodings, monitoring
the request progress with Observers...
Related Links
-------------
Package home: http://pear.php.net/package/HTTP_Request2
Changelog: http://pear.php.net/package/HTTP_Request2/download/0.3.0
Download: http://download.pear.php.net/package/HTTP_Request2-0.3.0.tgz
Authors
-------
Alexey Borzov (lead)