Re: minimum PHP version

From: Date: Fri, 30 Dec 2011 04:54:13 +0000
Subject: Re: minimum PHP version
References: 1 2  Groups: php.pear.qa 
Request: Send a blank email to pear-qa+get-5971@lists.php.net to get a copy of this message
On Wed, Dec 28, 2011 at 6:28 PM, A.L.E.C <alec@alec.pl> wrote: > On 26.12.2011 17:30, Daniel Convissor wrote: > > Hi Core and QA Folks: > > > > pear-core's current minimum PHP version is 4.4.0. Considering 4.4.9 was > > released in August of 2008 and 5.2 is even deprecated at this point, and > > PEAR excludes PHP 5 versions through 5.1.5, can we update the minimum > > requirement to 5.1.6, please? > > > > I am asking due to the problem raised in > > http://pear.php.net/bugs/bug.php?id=19153 lead me to make > > the following > > changes: > > > > https://github.com/pear/pear-core/commit/6cbc32b6cf79094fb267621ed2090567eca41bd4 > > But those changes require PHP 5. > > > > What are your thoughts? > > People using PHP4 are not interested in PHP fixes. I think they should > also be leaved without PEAR packages' fixes. If they are using old PHP > version they must use old versions of PEAR packages too. > > In my opinion our php-version-bc-break rule (package name change > required) is outdated and should be removed or should be changed to > allow increasing of min. PHP version to 5.1.6 without package name change. > > To be honest, I agree with your broad sentiment - if you are using PHP4, nuts to you. PHP itself has cut you off. But as a community we put it out there: No BC breaks. We swore our way forward is to make another major version of the package. I think there's a lot possible with non stable packages making the appropriate BC break and upping to PHP 5.*.*. I'm less certain about stable packages - PEAR itself.

« previous php.pear.qa (#5971) next »