RE: [PHP-PEAR] Getopt class
| From: | Colin Viebrock | Date: | Thu, 11 Jan 2001 18:03:25 +0000 |
| Subject: | RE: [PHP-PEAR] Getopt class | ||
| References: | 1 | Groups: | php.pear |
| Request: | Send a blank email to php-pear+get-957@lists.php.net to get a copy of this message | ||
> Somehow calling it Getopt_Getopt doesn't seem nice. Especially when
> you call the function Getopt_Getopt::getopt(). :)
Yeah, well ... at least it would be obvious what the class does. :)
But seriously, Getopt_Standard, or Getopt_Simple, or something? I'm
taking those names from CPAN, BTW, not commenting on your code.
Keep in mind that someone will eventually write another class that
does something similar or extends the functionality of your class.
What will they name it? And where will they put it?
- Colin